EU - PRODUCTION - pay-by link transaction interruptions

Incident Report for MPS

Resolved

Incident resolved at 12:09PM cause (DDOS attack on provider infra)
Posted Apr 02, 2026 - 14:17 CEST

Identified

Incident affecting PayU pay-by link transcation over payment provider, customers may not able to use payment methods (provided by PayU Europe),
Posted Apr 02, 2026 - 11:00 CEST