Delay in Invoices of March 2024
Incident Report for MPS
Resolved
The invoices of March will be sent with the invoices for April.
Posted Apr 30, 2024 - 15:18 CEST
Identified
Dear Merchants,

The invoices for the month of March 2024 will be delayed due to an internal accounting system problem.
We are working on a fix and we hope to deliver the invoices as soon as possible.

Please inform your accounting departments.

We apologize for the inconvenience caused.

Your MPS Team
Posted Apr 08, 2024 - 11:16 CEST
This incident affected: EUROPE LIVE (EU Production API).