EU - PRODUCTION - Elevated API Errors - Sanctions Screening Service

Incident Report for MPS

Resolved

We have not noted any errors since 11:53 AM.

The root cause was a network issue in the datacenter of our sanctions screening provider.

A detailed root cause analysis is still performed and mitigation measures for the future are explored.

Please reach out to mps.support@jpmmps.com if you would like to receive more detailed information.
Posted Jul 10, 2025 - 13:47 CEST

Monitoring

We see that the service is restored again since 11:53 AM.

We are waiting for an official confirmation and are monitoring the system.
Posted Jul 10, 2025 - 12:00 CEST

Update

Unfortunately the situation is still not fixed on the provider side.
We are in direct contact and we hope that the service is restored asap.
Posted Jul 10, 2025 - 10:27 CEST

Identified

We're experiencing an elevated level of API errors from our Compliance provider for the last 30min and are currently looking into the issue and will provide further updates as soon as possible.

Please check back on https://jpmmps.statuspage.io for further updates.

We thank those affected for their patience and understanding as our teams work to address this!
Posted Jul 10, 2025 - 09:27 CEST
This incident affected: EU LIVE (EU Production API).