EU - PRODUCTION - Elevated API Errors

Incident Report for MPS

Resolved

The incident has been resolved - we are continuing to monitor
Posted May 21, 2026 - 15:09 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 14:36 CEST

Update

Our provider is still working on a fix.
Posted May 21, 2026 - 12:02 CEST

Investigating

We're experiencing an elevated level of API errors for credit card processing for the last 2 hours since yesterday and are currently looking into the issue and will provide further updates as soon as possible.

Please check back on https://jpmmps.statuspage.io for further updates.

We thank those affected for their patience and understanding as our teams work to address this!
Posted May 21, 2026 - 11:05 CEST
This incident affected: EU LIVE (EU Production API).