EU - PRODUCTION - Elevated API Errors

Incident Report for MPS

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 10:32 CEST

Monitoring

The issue was identified and is currently being fixed by the provider. The API calls are successful again since 9:55 AM.
Posted Jul 09, 2026 - 10:20 CEST

Investigating

We're experiencing an elevated level of API errors from our Debtor Management Provider since midnight and are currently looking into the issue and will provide further updates as soon as possible.

Please check back on https://jpmmps.statuspage.io for further updates.

We thank those affected for their patience and understanding as our teams work to address this!
Posted Jul 09, 2026 - 08:40 CEST
This incident affected: EU LIVE (EU Production API).